Konec podpory. Pro sedm let starý Android 4.0 bude obtížnější vyvíjet aplikace

Reálně se změna mnoha lidí nedotkne, pokud ale používáte či vyvíjíte aplikace pro Android 4.0, zbystřete. Služby Google Play už s tímto systémem nepočítají.

1
Ilustrační foto
Ilustrační foto (autor: skeeze /Pixabay.com / upravil: Petr Urban)

Jak je to s rozšířením starých řad Androidu, nejspíš víte. Nové se rozšiřují pozvolna, zejména pak s novým zařízeními, proto se se staršími řadami setkáváme běžně. Google v minulém týdnu oznámil, že se nachýlil čas jedné z nich. Ne, že by vám Android 4.0 přestal fungovat, výrobce jej však omezí tím, že oficiálně přestává podporovat API 14 a 15.

Tyto dvě verze jsou spojené s uvedeným Androidem 4.0, který je již sedm let starý. Připomínám, že nese kódové označení Ice Cream Sandwich a nabídl nám modernější rozhraní Holo, softwarová hlavní tlačítka nebo odemykání zařízení obličejem. Konec podpory API znamená, že jej nebudou podporovat budoucí verze služby Google Play.

Nadcházející verze některých komponent ve vývojářské soupravě (SDK) ještě starší API podporovat mohou, ale není to již garantováno – a časem podpora stejně skončí. Tím pádem fakticky končí doba, kdy jste ještě mohli používat starší telefon s uvedeným systémem. V praxi se ovšem můžete setkat s tím, že aplikace už někdy odmítají fungovat i s novějšími verzemi Androidu.

Ani globálně rozhodnutí Googlu vadit nemusí, protože dnes už Android 4.0 pohání méně než procento všech zelených zařízení, jež se připojují ke službě Google Play. Pokud někdo vyvíjí aplikaci, která je v hojné míře používána na starších zařízeních, můžete ve vývoji pokračovat, ovšem za pomoci určitých triků a komplikací. Více na blogu Android Developers. Na svém smartphonu samozřejmě můžete nadále používat stávající verze aplikací.

Konec podpory. Pro sedm let starý Android 4.0 bude obtížnější vyvíjet aplikace

Ohodnoťte tento článek!
5 (100%) 3 hlas/ů

1 komentář