Firefox patrně zablokuje zásuvné moduly, s výjimkou aktuálního Flash Playeru

0

Skončí někdy téma „prohlížeče a zásuvné moduly“? Jednou snad ano, v nejbližší době ale nehrozí, že bychom mohli přestat řešit, jestli Flash Player či Java opět obsahují zranitelnosti. Nejpoužívanější Flash Player alespoň některé prohlížeče integrovaly, jmenovitě Chrome a Internet Explorer 10, takže se jejich výrobci rovněž starají o distribuci aktuálních verzí tohoto zásuvného modulu. Poslední slovo ještě neřekla ani Mozilla. Na svém blogu, věnovaném bezpečnosti, popisuje, co hodlá se zásuvnými moduly provést do budoucna.

Tip: Zásuvné moduly na vyžádání: spuštějte flashové objekty jen ručně

Počáteční plán počítá s tím, že Firefox zablokuje Flash Player 10.2 a starší. Postupně budou na černou listinu přidávány novější a novější verze, které ovšem stále obsahují díry a není radno je používat. Ve výsledku bude Firefox bez odmlouvání automaticky pouštět jen nejčerstvější vydání Flash Playeru. Starší, obvykle zranitelné verze budou k dispozici stále, ovšem jen na vyžádání. Mozilla využije funkce, kdy se na stránce místo objektu, vyžadujícího nějaký zásuvný modul, ukáže jen výzva k tomu, abyste na něj klepli, pokud chcete zobrazit obsah.

 

V případě, že bude modul obsahovat známé zranitelnosti, bude vám rovněž prozrazeno, že blokování probíhá právě kvůli možnému bezpečnostnímu riziku. Jakmile Mozilla dokončí práce na uživatelském prostředí, pravidla pro zásuvné moduly ještě zpřísní. Tentokráte bude zakázáno automatické načítání objektů ve všech ostatních modulech, včetně Silverlightu, Javy nebo Acrobat Readeru. V těchto případech nebudou blokovány jen staré verze, ale i ty aktuální. Spustit půjdou, ale jen na vyžádání.

Tento plán zní poměrně drsně, ale jedná se zřejmě o nejlepší kompromis pro uživatele, zásuvné moduly a bezpečnost. Kdyby se uživatelé změně hodně vzpírali, vývojový tým ji zřejmě neaplikuje. Bude sledovat zpětnou odezvu. Pakliže se bude organizace držet svého plánu, bude nakonec Firefox bez dalšího ptaní přehrávat jen objekty ve Flashi, za předpokladu, že budete mít aktuální Flash Player. Jak nastavit v různých prohlížečích funkci spuštění pluginů na vyžádání, jsme si dříve ukázali.

Zásuvný modul obsahuje zranitelnosti. Klepnutím ho aktivujete

Mozilla reaguje na současnou situaci, kdy zásuvné moduly stále představují vysoké bezpečnostní riziko. Obzvlášť to platí pro Javu. Právě ony také nejčastěji způsobují pády prohlížeče, vysoké vytížení procesoru a jiné podobné problémy. Adobe neziskovou organizaci v její snaze oficiálně podporuje. Podle serveru Mozilla.cz bychom se novinky mohli dočkat ve Firefoxu 22.

Zdroj: Mozilla Security Blog | ASSET Blog

Firefox patrně zablokuje zásuvné moduly, s výjimkou aktuálního Flash Playeru

Ohodnoťte tento článek!